Startup problems SBDesigner v5 - and AST error on LUA editor

Questions and information about Crank Software's Storyboard Designer

Moderator: jamiev

Startup problems SBDesigner v5 - and AST error on LUA editor

Postby anba » Thu Mar 23, 2017 4:48 am

Hello Crank Support,

for your information, I had some startup problems on the Storyboard Designer after upgrading to v5.0. I did never observe these problems on v4.x
It is Windows 7 Enterprise x64 machine, with an Intel Core i7

Following error message appeared, when launching the executable:

Failed to load the .INI shared library "C:\Program Files (x86)\Crank_Software\Storyboard_Designer\jre\bin\client\jvm.dll"

From some other Eclipse based softwares, this problem seems to be linked with the Java Virtual Machine. So I added following two lines to my Storyboard.ini file:

-vm
jre/bin/javaw.exe

This uses the JVM, delivered with Storyboard, instead of my Java 8 installation (x64). Now the Eclipse workbench loads, but it takes really long until the workspace selection shows up (maybe some network timeout?).
And I still get error messages, when I open a .LUA script file in the editor:


Problem Occured

'Requesting Script AST from selection' has encountered a problem.

An internal error occured during: "Requesting Script AST from selection".


Details:
An internal error occurred during: "Requesting Script AST from selection".
org.eclipse.ldt.core.internal.ast.models.common.LuaSourceRoot cannot be cast to org.eclipse.koneki.ldt.core.internal.ast.models.common.LuaSourceRoot


Any help would be appreciated.
Could it be an issue when installing Storyboard v5.0 over an existing v4.x installation? I thought modern installers should not have issues in this case, also the SBEngine uses its own subfolder, depending on the version.


Thanks,
Andreas
anba
 
Posts: 12
Joined: Fri Nov 18, 2016 2:10 am

Re: Startup problems SBDesigner v5 - and AST error on LUA ed

Postby anba » Thu Mar 30, 2017 12:07 am

Hello Crank Support,

as it started annoying me that I was unable to edit LUA scripts in the editor, without the error showing up, I decided to completely uninstall and reinstall Crank SB v5.0 from scratch.

Now it works!

So I assume installing v5.0 over an existing v4.2 installation is a bad idea, even though the installer moves all old files that it will overwrite to the rollback folder.
Perhaps it has something to do with eclipse namespace packages that have been renamed and thus not cleanly removed on the version change (like: [org.eclipse.ldt...] vs. [org.eclipse.koneki.ldt...]), these may exist twice after installation and lead to problems, when the eclipse environment loads.

Anyways, I am fine, but if more users experience this behavior, maybe have a look at the install procedure, or offer uninstalling the existing versions first.


Andreas
anba
 
Posts: 12
Joined: Fri Nov 18, 2016 2:10 am


Return to Storyboard Designer

Who is online

Users browsing this forum: No registered users and 4 guests

cron