module 'mime.core' not found

Questions and information about Crank Software's Storyboard Engine

Moderator: jamiev

module 'mime.core' not found

Postby yanglei » Fri Jan 13, 2017 12:57 am

I'm trying to run a Storyboard 4.2.1 application Demo, it´s from crank´s public svn repository. My target board is I.MX6 Sabre smart devices, and the OS is QNX 6.6. The environment LD_LIBRARY_PATH and the SB_PLUGINS are set, I use ¨qnx-6_6-armv7le-opengles_2.0-screen-obj¨ runtime folder but I met the error like below:
Code: Select all
# export GRE_PLUGINS=/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/lib/:/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins:/usr/lib
# export SB_PLUGINS=/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins
# export LD_LIBRARY_PATH=/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/lib:$LD_LIBRARY_PATH
# /dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/bin/sbengine -vvvv -- /dos/JeepCluster/JeepCluster2015.gapp
INFO   [0.022]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-animation.so]
INFO   [0.043]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-capture-playback.so]
INFO   [0.105]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-circle.so]
INFO   [0.123]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-dynamic-rext.so]
INFO   [0.146]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-effects-3d.so]
INFO   [0.167]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-event-redirect.so]
INFO   [0.189]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-gesture.so]
INFO   [0.210]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-greio.so]
INFO   [0.231]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-logger.so]
INFO   [0.277]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-lua.so]
INFO   [0.397]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-model3d.so]
INFO   [0.418]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-poly.so]
INFO   [0.451]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-rext-external.so]
INFO   [0.475]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-screen-3d.so]
INFO   [0.497]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-screen-dump.so]
INFO   [0.520]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-screen-path.so]
INFO   [0.539]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-screen-scale.so]
INFO   [0.557]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-system.so]
INFO   [0.577]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/libgre-plugin-timer.so]
INFO   [0.654]:Detected plugin [/dos/qnx-6_6-armv7le-opengles_2.0-screen-obj/plugins/librender-plugin-opengles_2.0.so]
INFO   [0.666]:Initialize Data Manager []
INFO   [0.669]:Initialize Model Manager []
INFO   [0.674]:Initialize IO Manager []
INFO   [0.677]:Initialize Action Manager []
INFO   [0.682]:Initialize Render Manager []
INFO   [0.686]:Initialize Screen Manager []
INFO   [0.691]:Initialize Resource Manager []
EVENT  [0.813]:Data Event Register: [speed] --> [updateSpeedEvent]
EVENT  [0.819]:Data Event Register: [state] --> [setTypeEvent]
EVENT  [0.827]:Data Event Register: [adas.distanceWarning.distance] --> [updateDistanceWarning]
INFO   [0.880]:Initialize plugin: [animate (4.2.1.21580)] []
INFO   [0.886]:Initialize plugin: [capture_playback (4.2.1.21580)] []
INFO   [0.892]:Initialize plugin: [circle (4.2.1.21580)] []
INFO   [0.898]:Initialize plugin: [dynamic.rextension (4.2.1.21580)] []
INFO   [0.904]:Initialize plugin: [render_effect (4.2.1.21580)] []
INFO   [0.910]:Initialize plugin: [redirect (4.2.1.21580)] []
INFO   [0.916]:Initialize plugin: [gesture (4.2.1.21580)] []
INFO   [0.922]:Initialize plugin: [greio (4.2.1.21580)] []
WARN   [0.927]:GREIO receiver can't open @ [JeepCluster2015.gapp] 89
INFO   [0.933]:Initialize plugin: [logger (4.2.1.21580)] []
INFO   [0.939]:Initialize plugin: [lua (4.2.1.21580)] []
ACTION [0.958]:Loading Lua script [callbacks.lua]
ACTION [0.988]:Loading Lua script [dkjson.lua]
ACTION [1.054]:Loading Lua script [ltn12.lua]
ACTION [1.076]:Loading Lua script [mime.lua]
ERROR  [1.106]:Problem loading Lua script [mime.lua] /dos/JeepCluster/scripts/mime.lua:20: module 'mime.core' not found:
        no field package.preload['mime.core']
        no file '/dos/JeepCluster/scripts/mime/core.lua'
        no file './mime/core.lua'
        no file '/usr/local/share/lua/5.1/mime/core.lua'
        no file '/usr/local/share/lua/5.1/mime/core/init.lua'
        no file '/usr/local/lib/lua/5.1/mime/core.lua'
        no file '/usr/local/lib/lua/5.1/mime/core/init.lua'
        no file '/dos/JeepCluster/scripts/qnx-armle/mime/core.so'
        no file './mime/core.so'
        no file '/usr/local/lib/lua/5.1/mime/core.so'
        no file '/usr/local/lib/lua/5.1/loadall.so'
        no file '/dos/JeepCluster/scripts/qnx-armle/mime.so'
        no file './mime.so'
        no file '/usr/local/lib/lua/5.1/mime.so'
        no file '/usr/local/lib/lua/5.1/loadall.so'
ERROR  [1.180]:LUA failed to load all scripts
INFO   [1.195]:Finalize animate
INFO   [1.198]:Finalize capture_playback
INFO   [1.202]:Finalize circle
INFO   [1.205]:Finalize dynamic.rextension
INFO   [1.209]:Finalize render_effect
INFO   [1.212]:Finalize redirect
INFO   [1.215]:Finalize gesture
INFO   [1.218]:Finalize greio
INFO   [1.222]:Finalize logger
Failed to run engine using file: /dos/JeepCluster/JeepCluster2015.gapp

Any suggestion?
yanglei
 
Posts: 2
Joined: Thu Jan 12, 2017 10:53 pm

Re: module 'mime.core' not found

Postby Evan » Fri Jan 13, 2017 9:41 am

Hello,

There is a Lua module (core.so) that is required to run this sample but is not included in the default release package of the QNX runtime you are using, and so the application can't find it. Please contact support (support@cranksoftware.com) with the sample and the runtime you are using and we will get you the libraries you need to run it.

Thanks,
Evan
Evan
 
Posts: 20
Joined: Wed Aug 27, 2014 7:29 am

Re: module 'mime.core' not found

Postby yanglei » Sat Jan 14, 2017 3:18 am

Thank you, Evan, is will be very helpful.
Evan wrote:Hello,

There is a Lua module (core.so) that is required to run this sample but is not included in the default release package of the QNX runtime you are using, and so the application can't find it. Please contact support (support@cranksoftware.com) with the sample and the runtime you are using and we will get you the libraries you need to run it.

Thanks,
Evan
yanglei
 
Posts: 2
Joined: Thu Jan 12, 2017 10:53 pm


Return to Storyboard Engine

Who is online

Users browsing this forum: No registered users and 2 guests

cron