Page 1 of 1

Text not visible

PostPosted: Wed Dec 12, 2018 11:34 am
by bobhibberdine
Hello,

I put together a _very_ simple model consisting of a white background with a line of black text. When I simulate the model it works fine but when I run it on my RT 1050 EVB (running FreeRTOS) the text is not visible.
I have the existing Coffee Machine demo project which works fine on my board (text is visible) and I use the same C program to render my simple screen so it _should_ work!
I have tried changing the font type, and all sorts of other settings without success.

Does anyone have any idea what I am doing wrong?

Thanks & Regards,
Bob

Re: Text not visible

PostPosted: Wed Dec 12, 2018 11:58 am
by garry
Hi Bob,

It is possible that you have not exported the Resource Header file exactly right when you are generating the sbengine_model.h file.

Can you check the the 'Bitmap Fonts' option on the Export Configuration screen is not checked as we have not built-in the bitmap font support to the runtime that you are using.

[Edit: Bitmap Fonts is set ON by default for new projects. We use full Freetype fonts on this platform so you need to deselect...]
Regards,
Garry

Re: Text not visible

PostPosted: Wed Dec 12, 2018 12:32 pm
by bobhibberdine
Hi Garry,

Yup, that was it. Thanks again!

Bob